---
cve: "CVE-2026-42271"
severity: "HIGH"
cvss: 8.7
epss: "91.4%"
vendor: "berriai"
kev: true
exploited: true
published: "2026-05-08 04:16:21"
tags: [cve, security, high]
source: tsecurity.de CVE-Dossier
exported: "2026-11-06T04:13:53+01:00"
---

# CVE-2026-42271

> 8.7 HIGH · ⚠️ CISA KEV (151 Tage) · 🔓 Exploited · 🧪 PoC

## Beschreibung

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

## CNA-Record (Kanon, cvelistV5)

- CNA: **GitHub_M**
- State: PUBLISHED
- Stand: 2026-07-15 00:57:49
- CNA-CVSS: **8.7** (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N`)

## CISA-Anreicherung (vulnrichment/ADP)

- CISA KEV seit: **08.06.2026**
- CISA-SSVC (Coordinator, v2.0.3):
  - Exploitation: **active**
  - Automatable: **no**
  - Technical Impact: **total**

## CVSS-Vektor

```
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N
```

| Metrik | Wert | Bewertung |
|---|---|---|
| AV Angriffsvektor | Netzwerk | bad |
| AC Komplexität | Gering | bad |
| PR Privilegien | Gering | warn |
| UI Interaktion | Keine | bad |

## Schwachstellen-Klasse

- **CWE-78** — Improper Neutralization of Special Elements used in an OS Command
  The product constructs all or part of an OS command using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the intended OS command before it is sent to a downstream component.
- **CWE-77** — Improper Neutralization of Special Elements used in a Command
  The product constructs all or part of a command using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the intended command when it is sent to a downstream component.

## Angriffsmuster (CAPEC)

- [CAPEC-6 — Argument Injection](https://capec.mitre.org/data/definitions/6.html) _(Severity: High)_
- [CAPEC-15 — Command Delimiters](https://capec.mitre.org/data/definitions/15.html) _(Severity: High)_
- [CAPEC-43 — Exploiting Multiple Input Interpretation Layers](https://capec.mitre.org/data/definitions/43.html) _(Severity: High)_
- [CAPEC-88 — OS Command Injection](https://capec.mitre.org/data/definitions/88.html) _(Severity: High)_
- [CAPEC-108 — Command Line Execution through SQL Injection](https://capec.mitre.org/data/definitions/108.html) _(Severity: Very High)_

## Patch verfügbar (OSV)

- e0d5c28db02b3219dbd944666a55f49732197922 (Commit)

## BSI-Hinweise (deutsch)

- [LiteLLM: Mehrere Schwachstellen](https://wid.cert-bund.de/portal/wid/sicherheitshinweis/WID-SEC-W-2026-1288) — _BSI-Einstufung: kritisch_
  Ein Angreifer kann mehrere Schwachstellen in LiteLLM ausnutzen, um einen SQL-Injection-Angriff durchzuführen und sich unbefugten Zugriff zu verschaffen oder um beliebigen Programmcode mit den Rechten des Dienstes auszuführen

## Referenzen

- <https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g>
- <https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable>
- <https://access.redhat.com/errata/RHSA-2026:27784>
- <https://access.redhat.com/errata/RHSA-2026:28960>
- <https://access.redhat.com/errata/RHSA-2026:30056>
- <https://access.redhat.com/security/cve/CVE-2026-42271>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2467924>
- <https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json>
- <https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271>

---
_Exportiert aus dem [tsecurity.de CVE-Dossier](https://tsecurity.de/sicherheitsluecken/cve-2026-42271/) · Datenquellen: EUVD (ENISA), NVD, OSV, CISA KEV, FIRST EPSS, Exploit-DB, BSI WID (CSAF)_
