1. Reverse Engineering >
  2. Sicherheitslücken >
  3. mruby 1.4.1 kernel.c init_copy memory corruption

ArabicEnglishFrenchGermanGreekItalianJapaneseKoreanPersianPolishPortugueseRussianSpanishTurkishVietnamese

mruby 1.4.1 kernel.c init_copy memory corruption


Exploits vom | Direktlink: vuldb.com Nachrichten Bewertung

A vulnerability classified as critical was found in mruby 1.4.1 (Programming Language Software). Affected by this vulnerability is the function init_copy of the file kernel.c. There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product....
https://vuldb.com/?id.118963

Externe Quelle mit kompletten Inhalt anzeigen


Zur Startseite von Team IT Security

➤ Weitere Beiträge von Team Security | IT Sicherheit

Nautilus - A Grammar Based Feedback Fuzzer

vom 737.9 Punkte ic_school_black_18dp
Nautilus is a coverage guided, grammar based fuzzer. You can use it to improve your test coverage and find more bugs. By specifying the grammar of semi valid inputs, Nautilus is able to perform complex mutation and to uncover more interesting test ca

Local Privilege Escalation in Win32k.sys Through Indexed Color Palettes

vom 263.6 Punkte ic_school_black_18dp
This is the second in our series of Top 5 interesting cases from 2019. Each of these bugs has some element that sets them apart from the more than 1,000 advisories released by the program this year. Today’s blog looks a local privilege escalation in t

USN-4118-1: Linux kernel (AWS) vulnerabilities

vom 208.94 Punkte ic_school_black_18dp
linux-aws vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 18.04 LTS Ubuntu 16.04 LTS Summary Several security issues were fixed in the Linux kernel. Software Description linux-aws - Linux kernel for Amazon Web Services

mruby 1.4.1 kernel.c init_copy Pufferüberlauf

vom 207.67 Punkte ic_school_black_18dp
In mruby 1.4.1 wurde eine kritische Schwachstelle entdeckt. Dabei geht es um die Funktion init_copy der Datei kernel.c. Durch das Beeinflussen mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle ausgenutzt werden. CWE definiert das Proble

mruby bis 1.2.0 gc.c mark_context_stack Pufferüberlauf

vom 204.97 Punkte ic_school_black_18dp
Es wurde eine kritische Schwachstelle in mruby bis 1.2.0 ausgemacht. Dabei betrifft es die Funktion mark_context_stack der Datei gc.c. Mittels dem Manipulieren mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle (Use-After-Free) ausgenu

USN-4226-1: Linux kernel vulnerabilities

vom 200.83 Punkte ic_school_black_18dp
linux, linux-aws, linux-aws-5.0, linux-azure, linux-gcp, linux-gke-5.0, linux-kvm, linux-oem-osp1, linux-oracle, linux-oracle-5.0, linux-raspi2 vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 19.04 Ubuntu 18.04 LTS

USN-3361-1: Linux kernel (HWE) vulnerabilities

vom 200.36 Punkte ic_school_black_18dp
Ubuntu Security Notice USN-3361-1 21st July, 2017 linux-hwe vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.04 LTS Summary Several security issues were fixed in the Linux kernel. Software descripti

USN-4284-1: Linux kernel vulnerabilities

vom 191.48 Punkte ic_school_black_18dp
linux, linux-aws, linux-azure-5.3, linux-gcp, linux-gcp-5.3, linux-hwe, linux-kvm, linux-oracle, linux-raspi2, linux-raspi2-5.3 vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 19.10 Ubuntu 18.04 LTS Summary Several secur

USN-4287-1: Linux kernel vulnerabilities

vom 181.94 Punkte ic_school_black_18dp
linux, linux-aws, linux-aws-hwe, linux-azure, linux-gcp, linux-gke-4.15, linux-hwe, linux-kvm, linux-oracle, linux-raspi2, linux-snapdragon vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 18.04 LTS Ubuntu 16.04

USN-3619-1: Linux kernel vulnerabilities

vom 166.2 Punkte ic_school_black_18dp
linux, linux-aws, linux-kvm, linux-raspi2, linux-snapdragon vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.04 LTS Summary Several security issues were fixed in the Linux kernel. Software Description l

USN-4287-2: Linux kernel (Azure) vulnerabilities

vom 157.52 Punkte ic_school_black_18dp
linux-azure vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 14.04 ESM Summary Several security issues were fixed in the Linux kernel. Software Description linux-azure - Linux kernel for Microsoft Azure Cloud systems Details USN-4287

USN-4225-1: Linux kernel vulnerabilities

vom 156.73 Punkte ic_school_black_18dp
linux, linux-aws, linux-azure, linux-azure-5.3, linux-gcp, linux-gcp-5.3, linux-kvm, linux-oracle, linux-raspi2 vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 19.10 Ubuntu 18.04 LTS Summary Several secur

Team Security Diskussion über mruby 1.4.1 kernel.c init_copy memory corruption