1. Server >
  2. Unix Server >
  3. DSA-4794 mupdf - security update

ArabicEnglishFrenchGermanGreekItalianJapaneseKoreanPersianPolishPortugueseRussianSpanishTurkishVietnamese

DSA-4794 mupdf - security update


Unix Server vom | Direktlink: debian.org Nachrichten Bewertung

A heap-based buffer overflow flaw was discovered in MuPDF, a lightweight PDF viewer, which may result in denial of service or the execution of arbitrary code if malformed documents are opened.

...
https://www.debian.org/security/2020/dsa-4794

Externe Quelle mit kompletten Inhalt anzeigen


Zur Startseite von Team IT Security

➤ Weitere Beiträge von Team Security | IT Sicherheit

MuPDF bis 1.9 pdf-object.c pdf_to_num Denial of Service

vom 371.58 Punkte ic_school_black_18dp
In MuPDF bis 1.9 wurde eine Schwachstelle entdeckt. Sie wurde als problematisch eingestuft. Hierbei betrifft es die Funktion pdf_to_num der Datei pdf-object.c. Durch das Manipulieren mit einer unbekannten Eingabe kann eine Denial of Service-Schwachstelle

Artifex MuPDF bis 1.9 Mujstest jstest_main.c main Pufferüberlauf

vom 229.48 Punkte ic_school_black_18dp
Es wurde eine kritische Schwachstelle in Artifex MuPDF bis 1.9 ausgemacht. Hiervon betroffen ist die Funktion main der Datei jstest_main.c der Komponente Mujstest. Durch Beeinflussen mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstell

Artifex MuPDF bis 1.9 Mujstest jstest_main.c my_getline Pufferüberlauf

vom 184.74 Punkte ic_school_black_18dp
In Artifex MuPDF bis 1.9 wurde eine kritische Schwachstelle ausgemacht. Betroffen ist die Funktion my_getline der Datei jstest_main.c der Komponente Mujstest. Dank der Manipulation mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle (Ou

USN-3415-2: tcpdump vulnerabilities

vom 135.39 Punkte ic_school_black_18dp
Ubuntu Security Notice USN-3415-2 13th September, 2017 tcpdump vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 12.04 LTS Summary Several security issues were fixed in tcpdump Software description tcpdump

USN-3415-1: tcpdump vulnerabilities

vom 133.1 Punkte ic_school_black_18dp
Ubuntu Security Notice USN-3415-1 13th September, 2017 tcpdump vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 17.04 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Summary Several security issues were fixe

Linux Kernel bis 4.6 System Call Handler mm/percpu.c mmap/bpf Denial of Service

vom 129.44 Punkte ic_school_black_18dp
Eine problematische Schwachstelle wurde in Linux Kernel bis 4.6, ein Betriebssystem, ausgemacht. Hierbei geht es um die Funktion mmap/bpf der Datei mm/percpu.c der Komponente System Call Handler. Durch Beeinflussen mit einer unbekannten Eingabe kann ei

Linux Kernel bis 4.6 System Call Handler mm/percpu.c mmap/bpf Denial of Service

vom 129.44 Punkte ic_school_black_18dp
Eine problematische Schwachstelle wurde in Linux Kernel bis 4.6, ein Betriebssystem, ausgemacht. Hierbei geht es um die Funktion mmap/bpf der Datei mm/percpu.c der Komponente System Call Handler. Durch Beeinflussen mit einer unbekannten Eingabe kann ei

Artifex MuPDF vor 1912de5f08e90af1d9d0a9791f58ba3afdb9d465 pdf-op-run.c pdf_run_xobject Denial of Service

vom 127.9 Punkte ic_school_black_18dp
In Artifex MuPDF wurde eine Schwachstelle gefunden. Sie wurde als problematisch eingestuft. Hierbei betrifft es die Funktion pdf_run_xobject der Datei pdf-op-run.c. Durch die Manipulation mit einer unbekannten Eingabe kann eine Denial of Service-Schwac

MuPDF bis 1.12.0 pdf/pdf-cmap.c pdf_lookup_cmap_full Pufferüberlauf

vom 127.9 Punkte ic_school_black_18dp
In MuPDF bis 1.12.0 wurde eine Schwachstelle gefunden. Sie wurde als kritisch eingestuft. Es geht um die Funktion pdf_lookup_cmap_full der Datei pdf/pdf-cmap.c. Durch die Manipulation mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle (Stack-based) ausgenutzt

MuPDF bis 1.12.0 PDF Parser Pufferüberlauf

vom 127.9 Punkte ic_school_black_18dp
Es wurde eine Schwachstelle in MuPDF bis 1.12.0 ausgemacht. Sie wurde als kritisch eingestuft. Es geht dabei um eine unbekannte Funktion der Komponente PDF Parser. Mittels dem Manipulieren mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle ausgenutzt

MuPDF bis 1.12.0 PDF Parser Assertion Denial of Service

vom 127.9 Punkte ic_school_black_18dp
Es wurde eine Schwachstelle in MuPDF bis 1.12.0 gefunden. Sie wurde als problematisch eingestuft. Betroffen hiervon ist eine unbekannte Funktion der Komponente PDF Parser. Mit der Manipulation mit einer unbekannten Eingabe kann eine Denial of Service-

MuPDF bis 1.12.0 PDF Parser Use-After-Free Pufferüberlauf

vom 127.9 Punkte ic_school_black_18dp
Eine Schwachstelle wurde in MuPDF bis 1.12.0 gefunden. Sie wurde als problematisch eingestuft. Es geht hierbei um eine unbekannte Funktion der Komponente PDF Parser. Durch Manipulation mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle (Use-After-

Team Security Diskussion über DSA-4794 mupdf - security update