TSEC NEWS: 06.05.21 Cron-Job Fehlerhaft nach PHP Update + PWA mobile + Desktop / 04.05.21 - Android App von TSECURITY 28.04.21 - NEUER SERVER // 26.04.21 ++ Download the Electron-App für tsecurity.de // Über 550 Feed-Quellen


❈ Some of these libraries may not be found correctly (Anaconda the cause here?)

Linux Tipps reddit.com

Does anyone have experience with this kind of error when installing a QT application? My guess is, anaconda has something to do with it in the present case. I am thankful for any help.

aking package: lightly-qt 0.4-1 (Mon 08 Feb 2021 10:05:23 CET)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> WARNING: Using existing $srcdir/ tree
==> Starting build()…
– The C compiler identification is GNU 10.2.0
– The CXX compiler identification is GNU 10.2.0
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Check for working C compiler: /usr/bin/cc - skipped
– Detecting C compile features
– Detecting C compile features - done
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Check for working CXX compiler: /usr/bin/c++ - skipped
– Detecting CXX compile features
– Detecting CXX compile features - done
Installing in /usr. Run /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/prefix.sh to set the environment for lightly.
– Looking for GLIBC
– Looking for GLIBC - found
– Performing Test _OFFT_IS_64BIT
– Performing Test _OFFT_IS_64BIT - Success
– Performing Test HAVE_DATE_TIME
– Performing Test HAVE_DATE_TIME - Success
– Found KF5CoreAddons: /usr/lib64/cmake/KF5CoreAddons/KF5CoreAddonsConfig.cmake (found version “5.78.0”)
– Found KF5GuiAddons: /usr/lib64/cmake/KF5GuiAddons/KF5GuiAddonsConfig.cmake (found version “5.78.0”)
– Found KF5ConfigWidgets: /usr/lib64/cmake/KF5ConfigWidgets/KF5ConfigWidgetsConfig.cmake (found version “5.78.0”)
– Found KF5WindowSystem: /usr/lib64/cmake/KF5WindowSystem/KF5WindowSystemConfig.cmake (found version “5.78.0”)
– Found Gettext: /usr/bin/msgmerge (found version “0.21”)
– Found KF5I18n: /usr/lib64/cmake/KF5I18n/KF5I18nConfig.cmake (found version “5.78.0”)
– Found KF5IconThemes: /usr/lib64/cmake/KF5IconThemes/KF5IconThemesConfig.cmake (found version “5.78.0”)
– Found KF5: success (found version “5.78.0”) found components: CoreAddons GuiAddons ConfigWidgets WindowSystem I18n IconThemes
– Found PkgConfig: /usr/bin/pkg-config (found version “1.7.3”)
– Found XCB_XCB: /usr/lib/libxcb.so (found version “1.14”)
– Found XCB: /usr/lib/libxcb.so (found version “1.14”) found components: XCB
– Warning: Property URL already set to “https://xcb.freedesktop.org/”, overriding it with “https://xcb.freedesktop.org
– Performing Test COMPILER_HAS_HIDDEN_VISIBILITY
– Performing Test COMPILER_HAS_HIDDEN_VISIBILITY - Success
– Performing Test COMPILER_HAS_HIDDEN_INLINE_VISIBILITY
– Performing Test COMPILER_HAS_HIDDEN_INLINE_VISIBILITY - Success
– Performing Test COMPILER_HAS_DEPRECATED_ATTR
– Performing Test COMPILER_HAS_DEPRECATED_ATTR - Success
– Found KF5Config: /usr/lib64/cmake/KF5Config/KF5ConfigConfig.cmake (found version “5.78.0”)
– Found KF5: success (found version “5.78.0”) found components: I18n Config GuiAddons IconThemes ConfigWidgets WindowSystem
– Warning: Property URL already set to “https://xcb.freedesktop.org”, overriding it with “https://xcb.freedesktop.org/
– Warning: Property URL already set to “https://xcb.freedesktop.org/”, overriding it with “https://xcb.freedesktop.org
Installing in /usr. Run /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/misc/kde4lightly/prefix.sh to set the environment for lightly.
– Found KF5: success (found version “5.78.0”) found components: CoreAddons Config
CMake Warning (dev) at /usr/share/ECM/modules/ECMPackageConfigHelpers.cmake:63 (message):
Your project already requires a version of CMake that includes the
find_dependency macro via the CMakeFindDependencyMacro module. You should
use CMakePackageConfigHelpers instead of ECMPackageConfigHelpers.
Call Stack (most recent call first):
misc/kde4lightly/CMakeLists.txt:12 (include)
This warning is for project developers. Use -Wno-dev to suppress it.
– The following OPTIONAL packages have been found:
Qt5Network (required version >= 5.9.7)
Qt5Qml (required version >= 5.9.7)
Qt5Quick
KF5FrameworkIntegration, KF5 Framework Integration, https://projects.kde.org/projects/frameworks/frameworkintegration
Required to use KStyle convenience functionalities in style
PkgConfig
XCB, X protocol C-language Binding, https://xcb.freedesktop.org
Required to pass style properties to native Windows on X11 Platform
Required to pass style properties to native Windows on X11 Platform
KF5Wayland
KF5Auth (required version >= 5.78.0)
KF5Codecs (required version >= 5.78.0)
KF5WidgetsAddons (required version >= 5.78.0)
KF5Service (required version >= 5.78.0)
KF5KCMUtils, KF5 KCM utils Framework, https://projects.kde.org/projects/frameworks/kcmutils
Required for lightly-settings5 application to build
Qt5Core (required version >= 5.14.0)
– The following REQUIRED packages have been found:
KDecoration2
Gettext
KF5I18n
KF5GuiAddons
KF5WindowSystem
KF5IconThemes (required version >= 5.78.0)
Qt5X11Extras
KF5ConfigWidgets (required version >= 5.78.0)
ECM (required version >= 0.0.13)
Qt5Widgets
Qt5
KF5CoreAddons
Qt5DBus (required version >= 5.14.0)
KF5Config
KF5
– Configuring done
CMake Warning at kdecoration/CMakeLists.txt:67 (add_library):
Cannot generate a safe runtime search path for target lightlydecoration
because files in some directories may conflict with libraries in implicit
directories:
runtime library [libxcb.so.1] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Xml.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5DBus.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Widgets.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Gui.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib Some of these libraries may not be found correctly.
CMake Warning at liblightlycommon/CMakeLists.txt:10 (add_library):
Cannot generate a safe runtime search path for target lightlycommon5
because files in some directories may conflict with libraries in implicit
directories:
runtime library [libQt5Gui.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib Some of these libraries may not be found correctly.
CMake Warning at kstyle/CMakeLists.txt:104 (add_library):
Cannot generate a safe runtime search path for target lightly because files
in some directories may conflict with libraries in implicit directories:
runtime library [libxcb.so.1] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Xml.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5DBus.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Widgets.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Gui.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib Some of these libraries may not be found correctly.
CMake Warning at kstyle/config/CMakeLists.txt:31 (add_executable):
Cannot generate a safe runtime search path for target lightly-settings5
because files in some directories may conflict with libraries in implicit
directories:
runtime library [libQt5Widgets.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Xml.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5DBus.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Gui.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib Some of these libraries may not be found correctly.
CMake Warning at kstyle/config/CMakeLists.txt:31 (add_executable):
Cannot generate a safe dependent library path for target lightly-settings5
because files in some directories may conflict with libraries in implicit
directories:
runtime library [libQt5DBus.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib Some of these libraries may not be found correctly.
CMake Warning at kstyle/config/CMakeLists.txt:11 (add_library):
Cannot generate a safe runtime search path for target kstyle_lightly_config
because files in some directories may conflict with libraries in implicit
directories:
runtime library [libQt5Xml.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Widgets.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5DBus.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Gui.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib Some of these libraries may not be found correctly.
CMake Warning at misc/kde4lightly/src/CMakeLists.txt:9 (add_executable):
Cannot generate a safe runtime search path for target kde4lightly because
files in some directories may conflict with libraries in implicit
directories:
runtime library [libQt5Widgets.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5Gui.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib runtime library [libQt5DBus.so.5] in /usr/lib may be hidden by files in: /home/meck/anaconda3/lib Some of these libraries may not be found correctly.
– Generating done
– Build files have been written to: /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build
Scanning dependencies of target lightly-settings5_autogen
Scanning dependencies of target kstyle_lightly_config_autogen
Scanning dependencies of target lightlycommon5_autogen
Scanning dependencies of target kde4lightly_autogen
[ 2%] Automatic MOC for target kstyle_lightly_config
[ 2%] Automatic MOC for target lightly-settings5
[ 4%] Automatic MOC for target kde4lightly
[ 4%] Automatic MOC for target lightlycommon5
AutoMoc subprocess error
The moc process failed to compile
“SRC:/kstyle/config/lightlystyleconfig.h”
into
“SRC:/build/kstyle/config/kstyle_lightly_config_autogen/EWIEGA46WW/moc_lightlystyleconfig.cpp”
Command
/home/meck/anaconda3/bin/moc -DKCOREADDONS_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB “-DTRANSLATION_DOMAIN=“lightly_style_config”” -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -Dkstyle_lightly_config_EXPORTS -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/config -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/animations -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/debug -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/liblightlycommon -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/liblightlycommon -I/home/meck/anaconda3/include/qt -I/home/meck/anaconda3/include/qt/QtCore -I/home/meck/anaconda3/mkspecs/linux-g++ -I/usr/include/qt -I/usr/include/qt/QtGui -I/usr/include/qt/QtWidgets -I/usr/include/qt/QtDBus -I/usr/include/KF5/KConfigCore -I/usr/include/KF5 -I/usr/include/KF5/KConfigWidgets -I/usr/include/KF5/KCodecs -I/usr/include/KF5/KWidgetsAddons -I/usr/include/KF5/KConfigGui -I/usr/include/qt/QtXml -I/usr/include/KF5/KAuth -I/usr/include/KF5/KCoreAddons -I/usr/include/KF5/KI18n -I/usr/include/c++/10.2.0 -I/usr/include/c++/10.2.0/x86_64-pc-linux-gnu -I/usr/include/c++/10.2.0/backward -I/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include -I/usr/local/include -I/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include-fixed -I/usr/include --include /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config/kstyle_lightly_config_autogen/moc_predefs.h --output-dep-file -o /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config/kstyle_lightly_config_autogen/EWIEGA46WW/moc_lightlystyleconfig.cpp /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/config/lightlystyleconfig.h
Output
Unknown option ‘output-dep-file’.
AutoMoc subprocess error
The moc process failed to compile
“SRC:/kstyle/config/lightlystyleconfigmodule.cpp”
into
“SRC:/build/kstyle/config/kstyle_lightly_config_autogen/include/lightlystyleconfigmodule.moc”
included by
“SRC:/kstyle/config/lightlystyleconfigmodule.cpp”
Command
/home/meck/anaconda3/bin/moc -DKCOREADDONS_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB “-DTRANSLATION_DOMAIN=“lightly_style_config”” -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -Dkstyle_lightly_config_EXPORTS -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/config -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/animations -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/debug -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/liblightlycommon -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/liblightlycommon -I/home/meck/anaconda3/include/qt -I/home/meck/anaconda3/include/qt/QtCore -I/home/meck/anaconda3/mkspecs/linux-g++ -I/usr/include/qt -I/usr/include/qt/QtGui -I/usr/include/qt/QtWidgets -I/usr/include/qt/QtDBus -I/usr/include/KF5/KConfigCore -I/usr/include/KF5 -I/usr/include/KF5/KConfigWidgets -I/usr/include/KF5/KCodecs -I/usr/include/KF5/KWidgetsAddons -I/usr/include/KF5/KConfigGui -I/usr/include/qt/QtXml -I/usr/include/KF5/KAuth -I/usr/include/KF5/KCoreAddons -I/usr/include/KF5/KI18n -I/usr/include/c++/10.2.0 -I/usr/include/c++/10.2.0/x86_64-pc-linux-gnu -I/usr/include/c++/10.2.0/backward -I/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include -I/usr/local/include -I/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include-fixed -I/usr/include --include /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config/kstyle_lightly_config_autogen/moc_predefs.h --output-dep-file -o /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config/kstyle_lightly_config_autogen/include/lightlystyleconfigmodule.moc /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/config/lightlystyleconfigmodule.cpp
Output
Unknown option ‘output-dep-file’.
AutoMoc subprocess error
The moc process failed to compile
“SRC:/kstyle/config/lightlystyleconfigmodule.h”
into
“SRC:/build/kstyle/config/kstyle_lightly_config_autogen/EWIEGA46WW/moc_lightlystyleconfigmodule.cpp”
Command
/home/meck/anaconda3/bin/moc -DKCOREADDONS_LIB -DQT_CORE_LIB -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_XML_LIB “-DTRANSLATION_DOMAIN=“lightly_style_config”” -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -Dkstyle_lightly_config_EXPORTS -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/config -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/animations -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/debug -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/liblightlycommon -I/home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/liblightlycommon -I/home/meck/anaconda3/include/qt -I/home/meck/anaconda3/include/qt/QtCore -I/home/meck/anaconda3/mkspecs/linux-g++ -I/usr/include/qt -I/usr/include/qt/QtGui -I/usr/include/qt/QtWidgets -I/usr/include/qt/QtDBus -I/usr/include/KF5/KConfigCore -I/usr/include/KF5 -I/usr/include/KF5/KConfigWidgets -I/usr/include/KF5/KCodecs -I/usr/include/KF5/KWidgetsAddons -I/usr/include/KF5/KConfigGui -I/usr/include/qt/QtXml -I/usr/include/KF5/KAuth -I/usr/include/KF5/KCoreAddons -I/usr/include/KF5/KI18n -I/usr/include/c++/10.2.0 -I/usr/include/c++/10.2.0/x86_64-pc-linux-gnu -I/usr/include/c++/10.2.0/backward -I/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include -I/usr/local/include -I/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include-fixed -I/usr/include --include /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config/kstyle_lightly_config_autogen/moc_predefs.h --output-dep-file -o /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/build/kstyle/config/kstyle_lightly_config_autogen/EWIEGA46WW/moc_lightlystyleconfigmodule.cpp /home/meck/.cache/yay/lightly-qt/src/Lightly-0.4/kstyle/config/lightlystyleconfigmodule.h
Output
Unknown option ‘output-dep-file’.
make[2]: *** [kstyle/config/CMakeFiles/kstyle_lightly_config_autogen.dir/build.make:77: kstyle/config/CMakeFiles/kstyle_lightly_config_autogen] Error 1
make[1]: *** [CMakeFiles/Makefile2:954: kstyle/config/CMakeFiles/kstyle_lightly_config_autogen.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
[ 4%] Built target kde4lightly_autogen
[ 4%] Built target lightlycommon5_autogen
[ 4%] Built target lightly-settings5_autogen
make: *** [Makefile:149: all] Error 2
==> ERROR: A failure occurred in build().
Aborting…
error making: lightly-qt

submitted by /u/LilSaindt
[link] [comments]...


Kompletten Artikel lesen (externe Quelle: https://www.reddit.com/r/linux/comments/lfac14/some_of_these_libraries_may_not_be_found/)

Zur Startseite

➤ Weitere Beiträge von Team Security | IT Sicherheit (tsecurity.de)

Some of these libraries may not be found correctly (Anaconda the cause here?)

vom 376.87 Punkte
Does anyone have experience with this kind of error when installing a QT application? My guess is, anaconda has something to do with it in the present case. I am thankful for any help. aking package: lightly-qt 0.4-1 (Mon 08 Feb 2021 10:05:23 CET) ==&g

Kconfig-Hardened-Check - A Tool For Checking The Hardening Options In The Linux Kernel Config

vom 337.66 Punkte
MotivationThere are plenty of Linux kernel hardening config options. A lot of them are not enabled by the major distros. We have to enable these options ourselves to make our systems more secure. But nobody likes checking configs manually. So let the compute

Announcing .NET Core 3.0

vom 241.78 Punkte
Announcing .NET Core 3.0 We’re excited to announce the release of .NET Core 3.0. It includes many improvements, including adding Windows Forms and WPF, adding new JSON APIs, support for ARM64 and improving performance across the board. C# 8 is als

HELP !!! HOW TO INTERPRET THIS RKHUNTER REPORT?

vom 224.94 Punkte
I posted all the warnings in final lines,so you dont need to read everything. ​ ​ Checking system commands... ​ Performing 'strings' command checks Checking 'strings' command [ OK ] ​ Performing 'shared libraries' checks Checking for preloa

USN-4118-1: Linux kernel (AWS) vulnerabilities

vom 205.58 Punkte
linux-aws vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 18.04 LTS Ubuntu 16.04 LTS Summary Several security issues were fixed in the Linux kernel. Software Description linux-aws - Linux kernel for Amazon Web Services

ConfigureAwait FAQ

vom 194.01 Punkte
.NET added async/await to the languages and libraries over seven years ago. In that time, it’s caught on like wildfire, not only across the .NET ecosystem, but also being replicated in a myriad of other languages and frameworks. It’s also seen a ton of im

Android Instant Apps: Best practices for managing download size

vom 182.64 Punkte
Posted by Maru Ahues Bouza, Developer Relations Partner, Google Play Android Instant Apps provides rich, native experiences at the tap of a web link. People can experience your app without upfront installation, enabling a higher level and quality

Rust/C++ interop in the Android Platform

vom 182.46 Punkte
Posted by Joel Galenson and Matthew Maurer, Android Team One of the main challenges of evaluating Rust for use within the Android platform was ensuring we could provide sufficient interoperability with our existing codebase. If Rust is to meet its goal

CentOS Blog: CentOS Community newsletter, June 2020 (#2006)

vom 180.48 Punkte
Dear CentOS enthusiast, We hope you are all doing well and staying healthy, and, as always, thank you for being part of this great community. In this edition: News Releases and updates Events SIG reports News User Survey Over the past month we have been conducting

Improving Stability with Private C/C++ Symbol Restrictions in Android N

vom 174.77 Punkte
Posted by Dimitry Ivanov & Elliott Hughes, Software Engineers As documented in the Android N behavioral changes, to protect Android users and apps from unforeseen crashes, Android N will restrict which libraries your C/C++ code can link against a

Improving Stability with Private C/C++ Symbol Restrictions in Android N

vom 174.77 Punkte
Posted by Dimitry Ivanov & Elliott Hughes, Software Engineers As documented in the Android N behavioral changes, to protect Android users and apps from unforeseen crashes, Android N will restrict which libraries your C/C++ code can link against a

Paramount Privileged Account Security Guidance (101) for CyberArk

vom 173.11 Punkte
Shadow Admins - The Stealthy Accounts That You Should Fear The Most, but Needn't AnymoreFolks,Today's post concerns CyberArk's guidance on Privileged Account Security, a subject that is paramount to cyber security today, and it likely impacts Trillions of $, as it imp

Team Security Diskussion über Some of these libraries may not be found correctly (Anaconda the cause here?)