1. Reverse Engineering >
  2. Exploits >
  3. Adobe Flash Player bis 27.0.0.183 AdobePSDK Pointer Pufferüberlauf

ArabicEnglishFrenchGermanGreekItalianJapaneseKoreanPersianPolishPortugueseRussianSpanishTurkishVietnamese
Anzeige

Adobe Flash Player bis 27.0.0.183 AdobePSDK Pointer Pufferüberlauf

Exploits vom 09.12.2017 um 01:00 Uhr | Quelle vuldb.com

Eine kritische Schwachstelle wurde in Adobe Flash Player bis 27.0.0.183 ausgemacht. Betroffen davon ist eine unbekannte Funktion der Komponente AdobePSDK Handler. Durch das Beeinflussen mit einer unbekannten Eingabe kann eine Pufferüberlauf-Schwachstelle (Pointer) ausgenutzt werden. Klassifiziert wurde die Schwachstelle durch CWE als CWE-119. Auswirkungen sind zu beobachten für Vertraulichkeit, Integrität und Verfügbarkeit.

Die Schwachstelle wurde am 09.12.2017 veröffentlicht. Auf security.gentoo.org kann das Advisory eingesehen werden. Die Identifikation der Schwachstelle findet seit dem 02.12.2016 als CVE-2017-3112 statt. Der Angriff kann über das Netzwerk passieren. Das Ausnutzen erfordert keine spezifische Authentisierung. Nicht vorhanden sind sowohl technische Details als auch ein Exploit zur Schwachstelle. Als Preis für einen Exploit ist zur Zeit ungefähr mit USD $5k-$25k zu rechnen (Preisberechnung vom 12/10/2017). Es kann davon ausgegangen werden, dass sich die Exploit-Preise für dieses Produkt in Zukunft fallend verhalten werden.

Für den Vulnerability Scanner Nessus wurde ein Plugin mit der ID 104547 (KB4048951: Security update for Adobe Flash Player (November 2017)) herausgegeben, womit die Existenz der Schwachstelle geprüft werden kann. Es wird der Family Windows : Microsoft Bulletins zugeordnet.

Ein Upgrade auf die Version 27.0.0.187 vermag dieses Problem zu beheben. Das Erscheinen einer Gegenmassnahme geschah vor und nicht erst nach der Veröffentlichung der Schwachstelle. Adobe hat entsprechend vorgängig reagiert.

Die Einträge 110415, 110416, 110417 und 110439 sind sehr ähnlich.

CVSSv3

VulDB Base Score: 6.3
VulDB Temp Score: 6.0
VulDB Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L/E:X/RL:O/RC:X
VulDB Zuverlässigkeit: High

CVSSv2

VulDB Base Score: 6.8 (CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
VulDB Temp Score: 5.9 (CVSS2#E:ND/RL:OF/RC:ND)
VulDB Zuverlässigkeit: High

CPE

Exploiting

Klasse: Pufferüberlauf / Pointer (CWE-119)
Lokal: Nein
Remote: Ja

Verfügbarkeit: Nein

Preisentwicklung: gleichbleibend
Aktuelle Preisschätzung: $0-$5k (0-day) / $0-$5k (Heute)

Nessus ID: 104547
Nessus Name: KB4048951: Security update for Adobe Flash Player (November 2017)
Nessus File: smb_nt_ms17_nov_4048951.nasl
Nessus Family: Windows : Microsoft Bulletins

OpenVAS ID: 866085
OpenVAS Name: Adobe Flash Player Security Updates( apsb17-33 )-Windows
OpenVAS File: gb_adobe_flash_player_apsb17-33_win.nasl
OpenVAS Family: General

Gegenmassnahmen

Empfehlung: Upgrade
Status: Offizieller Fix
0-Day Time: 0 Tage seit gefunden

Upgrade: Flash Player 27.0.0.187

Timeline

02.12.2016 CVE zugewiesen
14.11.2017 Gegenmassnahme veröffentlicht
09.12.2017 Advisory veröffentlicht
10.12.2017 VulDB Eintrag erstellt
10.12.2017 VulDB letzte Aktualisierung

Quellen

Advisory: security.gentoo.org
Bestätigung: helpx.adobe.com

CVE: CVE-2017-3112 (mitre.org) (nvd.nist.org) (cvedetails.com)
Siehe auch: 110415, 110416, 110417, 110439

Eintrag

Erstellt: 10.12.2017
Eintrag: 76% komplett
...

Jetzt externen Artikel / Webseite öffnen

1-Klick Newsbewertung

Social Media
"

Kommentiere zu Adobe Flash Player bis 27.0.0.183 AdobePSDK Pointer Pufferüberlauf