1. Server >
  2. Unix Server >
  3. USN-2859-1: Thunderbird vulnerabilities


ArabicEnglishFrenchGermanGreekItalianJapaneseKoreanPersianPolishPortugueseRussianSpanishTurkishVietnamese

USN-2859-1: Thunderbird vulnerabilities

RSS Kategorie Pfeil Unix Server vom | Quelle: ubuntu.com Direktlink öffnen

Ubuntu Security Notice USN-2859-1

13th January, 2016

thunderbird vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.10
  • Ubuntu 15.04
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

Several security issues were fixed in Thunderbird.

Software description

  • thunderbird - Mozilla Open Source mail and newsgroup client

Details

Andrei Vaida, Jesse Ruderman, Bob Clary, and Jesse Ruderman
discovered multiple memory safety issues in Thunderbird. If a user were
tricked in to opening a specially crafted message, an attacker could
potentially exploit these to cause a denial of service via application
crash, or execute arbitrary code with the privileges of the user invoking
Thunderbird. (CVE-2015-7201)

Ronald Crane discovered a buffer overflow through code inspection. If a
user were tricked in to opening a specially crafted website in a browsing
context, an attacker could potentially exploit this to cause a denial of
service via application crash, or execute arbitrary code with the
privileges of the user invoking Thunderbird. (CVE-2015-7205)

Abhishek Arya discovered an integer overflow when allocating large
textures. If a user were tricked in to opening a specially crafted
website in a browsing context, an attacker could potentially exploit this
to cause a denial of service via application crash, or execute arbitrary
code with the privileges of the user invoking Thunderbird. (CVE-2015-7212)

Ronald Crane dicovered an integer overflow when processing MP4 format
video in some circumstances. If a user were tricked in to opening a
specially crafted website in a browsing context, an attacker could
potentially exploit this to cause a denial of service via application
crash, or execute arbitrary code with the privileges of the user invoking
Thunderbird. (CVE-2015-7213)

Tsubasa Iinuma discovered a way to bypass same-origin restrictions using
data: and view-source: URLs. If a user were tricked in to opening a
specially crafted website in a browsing context, an attacker could
potentially exploit this to obtain sensitive information and read local
files. (CVE-2015-7214)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 15.10:
thunderbird 1:38.5.1+build2-0ubuntu0.15.10.1
Ubuntu 15.04:
thunderbird 1:38.5.1+build2-0ubuntu0.15.04.1
Ubuntu 14.04 LTS:
thunderbird 1:38.5.1+build2-0ubuntu0.14.04.1
Ubuntu 12.04 LTS:
thunderbird 1:38.5.1+build2-0ubuntu0.12.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Thunderbird to make
all the necessary changes.

References

CVE-2015-7201, CVE-2015-7205, CVE-2015-7212, CVE-2015-7213, CVE-2015-7214

...

Webseite öffnen Komplette Webseite öffnen

Newsbewertung

Kommentiere zu USN-2859-1: Thunderbird vulnerabilities






Ähnliche Beiträge

  • 1. USN-2934-1: Thunderbird vulnerabilities vom 201.06 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-2934-1 27th April, 2016 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.04 LTS Ubuntu 15.10 Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu
  • 2. USN-2859-1: Thunderbird vulnerabilities vom 196.35 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-2859-1 13th January, 2016 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 15.10 Ubuntu 15.04 Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu
  • 3. USN-2819-1: Thunderbird vulnerabilities vom 187.86 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-2819-1 1st December, 2015 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 15.10 Ubuntu 15.04 Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu
  • 4. USN-4064-1: Thunderbird vulnerabilities vom 164.39 Punkte ic_school_black_18dp
    thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 19.04 Ubuntu 18.10 Ubuntu 18.04 LTS Ubuntu 16.04 LTS Summary Several security issues were fixed in Thunderbird. Software Description thunde
  • 5. USN-3278-1: Thunderbird vulnerabilities vom 147.01 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3278-1 16th May, 2017 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 17.04 Ubuntu 16.10 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Summary Several securi
  • 6. USN-3321-1: Thunderbird vulnerabilities vom 147.01 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3321-1 5th July, 2017 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 17.04 Ubuntu 16.10 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Summary Several securi
  • 7. USN-2904-1: Thunderbird vulnerabilities vom 139.29 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-2904-1 8th March, 2016 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 15.10 Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several security issues were fixed
  • 8. USN-2973-1: Thunderbird vulnerabilities vom 139.29 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-2973-1 18th May, 2016 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.04 LTS Ubuntu 15.10 Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu
  • 9. USN-3023-1: Thunderbird vulnerabilities vom 139.29 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3023-1 18th July, 2016 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.04 LTS Ubuntu 15.10 Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu
  • 10. USN-3112-1: Thunderbird vulnerabilities vom 139.29 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3112-1 27th October, 2016 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.10 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu
  • 11. USN-3141-1: Thunderbird vulnerabilities vom 139.29 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3141-1 30th November, 2016 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.10 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu
  • 12. USN-3165-1: Thunderbird vulnerabilities vom 139.29 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3165-1 27th January, 2017 thunderbird vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 16.10 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several secu