logo
 
  1. IT-Security >
  2. Cyber Security Nachrichten >
  3. Larry Wall Approves Re-Naming Perl 6 To Raku


ArabicEnglishFrenchGermanGreekItalianJapaneseKoreanPersianPolishPortugueseRussianSpanishTurkishVietnamese

Larry Wall Approves Re-Naming Perl 6 To Raku

RSS Kategorie Pfeil IT Security Nachrichten vom | Quelle: developers.slashdot.org Direktlink öffnen

Long-time Slashdot reader hondo77 notes that Larry Wall has given his approval to the re-naming of Perl 6. In the "Path to Raku" pull request, Larry Wall indicated his approval, leaving this comment: I am in favor of this change, because it reflects an ancient wisdom: "No one sews a patch of unshrunk cloth on an old garment, for the patch will pull away from the garment, making the tear worse. Neither do people pour new wine into old wineskins. If they do, the skins will burst; the wine will run out and the wineskins will be ruined. No, they pour new wine into new wineskins, and both are preserved." "Perl 6 will become Raku, assuming the four people who haven't yet approved the pull request give their okay," reports the Register, adding that Perl 5 will then become simply Perl. Dozens of comments on that pull request have now already been marked as "outdated," and while a few contributors have made a point of abstaining from the approval process, reviewer Alex Daniel notes that "this pull request will be merged on October 14th if nobody in the list rejects it or requests more changes."

Read more of this story at Slashdot.

...

Webseite öffnen Komplette Webseite öffnen

Newsbewertung

Kommentiere zu Larry Wall Approves Re-Naming Perl 6 To Raku






Ähnliche Beiträge

  • 1. Larry Wall Approves Re-Naming Perl 6 To Raku vom 442.54 Punkte ic_school_black_18dp
    Long-time Slashdot reader hondo77 notes that Larry Wall has given his approval to the re-naming of Perl 6. In the "Path to Raku" pull request, Larry Wall indicated his approval, leaving this comment: I am in favor of this change, because it reflects
  • 2. Perl 5.8.9 UTF-8 Handler regexec.c Denial of Service vom 283.62 Punkte ic_school_black_18dp
    Allgemein scipID: 82792 Betroffen: Perl 5.8.9 Veröffentlicht: 20.04.2016 (Karl Williamson) Risiko: kritisch Erstellt: 25.04.2016 Eintrag: 78.4% komplett Beschreibung In Perl 5.8.9 wurde eine Schwachstelle entdeckt. Sie wurde als kritisch
  • 3. Command Injection Payload List vom 257.84 Punkte ic_school_black_18dp
    Command injection is an attack in which the goal is execution of arbitrary commands on the host operating system via a vulnerable application. Command injection attacks are possible when an application passes unsafe user supplied data (forms, cookies, HTTP headers
  • 4. New Video Peeks 'Inside the Head' of Perl Creator Larry Wall vom 235.69 Punkte ic_school_black_18dp
    "I was trained more as a linguist than a computer scientist," says Perl creator Larry Wall, "and some people would say it shows." An anonymous reader describes Wall's new video interview up on InfoQ: "With a natural language, you learn it as you go,"
  • 5. Perl bis 5.22.3-RC1/5.24.1-RC1 Module Loader erweiterte Rechte vom 189.08 Punkte ic_school_black_18dp
    Eine problematische Schwachstelle wurde in Perl bis 5.22.3-RC1/5.24.1-RC1 gefunden. Davon betroffen ist eine unbekannte Funktion der Komponente Module Loader. Dank der Manipulation mit einer unbekannten Eingabe kann eine erweiterte Rechte-Schwachstelle ausgenutzt w
  • 6. Is Perl 6 Being Renamed? vom 188.99 Punkte ic_school_black_18dp
    An anonymous reader quotes a blog post by Curtis Poe , a freelance Perl/Agile/testing consultant and the author of the Wrox book Beginning Perl: By now, many of you have seen the Perl 6 Github issue "Perl" in the name "Perl 6" is confusing and irritating.
  • 7. Perl bis 5.24.2/5.26.0 win32/perlhost.h CPerlHost::Add Environment Variable Pufferüberlauf vom 171.89 Punkte ic_school_black_18dp
    Eine kritische Schwachstelle wurde in Perl bis 5.24.2/5.26.0 ausgemacht. Betroffen davon ist die Funktion CPerlHost::Add der Datei win32/perlhost.h. Durch die Manipulation durch Environment Variable kann eine Pufferüberlauf-Schwachstelle (Stack-based) ausgenutzt werden. K
  • 8. Perl 5 XSLoader XSLoader/XSLoader_pm.PL erweiterte Rechte vom 163.3 Punkte ic_school_black_18dp
    Es wurde eine problematische Schwachstelle in Perl 5 entdeckt. Es betrifft eine unbekannte Funktion der Datei XSLoader/XSLoader_pm.PL der Komponente XSLoader. Mittels dem Manipulieren mit einer unbekannten Eingabe kann eine erweiterte Rechte-Schwachstelle
  • 9. USN-2916-1: Perl vulnerabilities vom 146.11 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-2916-1 2nd March, 2016 perl vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 15.10 Ubuntu 14.04 LTS Ubuntu 12.04 LTS Summary Several security issues were fixed in Perl.
  • 10. USN-3494-1: XML::LibXML vulnerability vom 128.92 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3494-1 27th November, 2017 libxml-libxml-perl vulnerability A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 17.10 Ubuntu 17.04 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Summary XML::LibXML
  • 11. USN-3478-1: Perl vulnerabilities vom 120.32 Punkte ic_school_black_18dp
    Ubuntu Security Notice USN-3478-1 13th November, 2017 perl vulnerabilities A security issue affects these releases of Ubuntu and its derivatives: Ubuntu 17.04 Ubuntu 16.04 LTS Ubuntu 14.04 LTS Summary Perl could be made to crash if it
  • 12. Perl, Perl 6, and Two Application Frameworks Release 2017 Advent Calendars vom 120.32 Punkte ic_school_black_18dp
    An anonymous reader writes: Friday saw this year's first new posts on the Perl Advent Calendar, a geeky tradition first started back in 2000. It describes Santa including Unicode's "Father Christmas" emoji by enabling UTF-8 encoding and then using the